activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rkopparthi <rkoppar...@gmail.com>
Subject HTTP 500 error with JBoss getting struck in ActiveMQ issued query
Date Tue, 03 Jun 2014 09:41:24 GMT
Hi,
Our application works fine in production but one or two customers are facing
issue with Jboss throwing HTTP 500 error to the client  where the ActiveMQ
broker seems to be issuing the below query repeatedly on JBoss restart.

"SELECT ID, MSG FROM dbo.ACTIVEMQ_MSGS WHERE CONTAINER=blah AND ID > blah
ORDER BY ID"

This query takes 2-3 minutes to execute and once it is done executing the
same query is fired again and again and system is not responsive.

The same sql query when we issue in our SQL server with values substituted
it runs fine in less than 30secs.

We are using the following ActiveMQ config

       <amq:persistenceAdapter>
                     <amq:jdbcPersistenceAdapter dataSource="#dataSource" 
                           useDatabaseLock="false">
                           <amq:statements>
                                  <amq:statements
tablePrefix="${hibernate.default_schema}." 
                                         />
                           </amq:statements>
                     </amq:jdbcPersistenceAdapter>
              </amq:persistenceAdapter>

We are unable to determine how to stop this SQL query from hanging entire
system with 500 errors.
We are thinking we have to change ActiveMQ Broker settings and not sure what
exactly to change to fix this error. We are using ActiveMQ 5.6 and Jboss
5.1.0 along with camel 2.9.2.
Appreciate quick response as we are already a week into this issue.

Thanks
Ravi





--
View this message in context: http://activemq.2283324.n4.nabble.com/HTTP-500-error-with-JBoss-getting-struck-in-ActiveMQ-issued-query-tp4681598.html
Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.

Mime
View raw message