activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Timothy Bish (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMQ-5143) Lost Message with LevelDB
Date Mon, 28 Apr 2014 19:48:17 GMT

    [ https://issues.apache.org/jira/browse/AMQ-5143?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13983460#comment-13983460
] 

Timothy Bish commented on AMQ-5143:
-----------------------------------

Have you tested against 5.9.1 or a 5.10-SNAPSHOT ?

> Lost Message with LevelDB
> -------------------------
>
>                 Key: AMQ-5143
>                 URL: https://issues.apache.org/jira/browse/AMQ-5143
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: activemq-leveldb-store
>    Affects Versions: 5.9.0
>         Environment: ubuntu server
>            Reporter: Rural Hunter
>            Priority: Critical
>
> I'm running activemq 5.9.0 with levelDB storage. Before, all my applications were running
fine. It means all messages in activemq are processed in time. Activemq worked also fine with
that. But recently, one of the application stopped to process messages due to system problem.
So the messages are piled in activemq queue. That was fine and as expected. 
> But one day, I found all the consumers can not consume messages from activemq. I checked
the queue depth in web console and found that, the enqueued counter is increasing but the
dequequed counter stops for all queues. If I click the queue name trying to browse the queue,
I found there was no message in it. Though the number of pending messages shows there are
many messages in it. And I'm sure there are actually messages in it because my application
consuming from one of the queues are broken.
> I checked my levelDB storage and it's about 40G. I had no idea what happened so I tried
to restart activemq. But after the restart I found all the messages are lost. I checked the
levelDB data and the old data files are still there(40G). 
> The new messages processing were fine right after the restart. But after several hours,
the same issue happened again. All consumers stopped consuming any messages. I restarted activemq
again the found the recently piled messages were lost too.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message