activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From wuzhaoxue <zhaoxue...@hotmail.com>
Subject why there is not support amqPersistenceAdapter in ActiveMQ 5.9 anymore ?
Date Tue, 29 Apr 2014 15:10:18 GMT
Hi  all

 

Who know why there is not support amqPersistenceAdapter in ActiveMQ 5.9
anymore ?

 

I configure the AMQ DB in ActiveMQ 5.9 , got the following error:

 

ERROR: java.lang.RuntimeException: Failed to execute start task. Reason:
org.springframework.beans.factory.xml.XmlBeanDefinitionStoreException: Line
89 in XML document from class path resource [activemq.xml] is invalid;
nested exception is org.xml.sax.SAXParseException; lineNumber: 89;
columnNumber: 92; cvc-complex-type.2.4.a: Invalid content was found starting
with element 'amqPersistenceAdapter'. One of
'{"http://activemq.apache.org/schema/core":jdbcPersistenceAdapter,
"http://activemq.apache.org/schema/core":journalPersistenceAdapter,
"http://activemq.apache.org/schema/core":kahaDB,
"http://activemq.apache.org/schema/core":levelDB,
"http://activemq.apache.org/schema/core":mKahaDB,
"http://activemq.apache.org/schema/core":memoryPersistenceAdapter,
"http://activemq.apache.org/schema/core":replicatedLevelDB,
WC[##other:"http://activemq.apache.org/schema/core"]}' is expected.

 

>From the following XSD file, I found that there is no any  description about
amqPersistenceAdapter in activemq-core-5.9.0.xsd.

http://activemq.apache.org/schema/core/activemq-core-5.9.0.xsd

 

Who know why delete the support of the amqPersistenceAdapter?

Is there no support anymore in the following version ?


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message