activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From artnaseef <...@artnaseef.com>
Subject Re: Queue Size with STOMP
Date Fri, 28 Mar 2014 04:41:26 GMT
Looks like that can happen when the request for stats does not match any
destinations.

>
>
> I configured the statisticsBrokerPlugin and it's working. I can see it in
> the
> admin UI in my browser. But when I try to get the stats using STOMP via
> SUBSCRIBE all I get is the headers. I don't get the following string for
> some reason:
>
> {memoryUsage=4241, dequeueCount=0, inflightCount=0, messagesCached=0,
> averageEnqueueTime=1759542.142857143, destinationName=queue://Test1,
> averageMessageSize=0.9501187648456056,
> brokerId=ID:winston.home-51097-1395977559758-0:1, memoryPercentUsage=0,
> size=4, producerCount=0, consumerCount=0, minEnqueueTime=1445683.0,
> brokerName=localhost, maxEnqueueTime=2326953.0, dispatchCount=22,
> expiredCount=0, enqueueCount=2, memoryLimit=745517875}
>
> There appears to be no body for the message, just headers. What's
> different
> about this then messages I put in the queue? I can get those with STOMP.
>
>
>
> _______________________________________________
> If you reply to this email, your message will be added to the discussion
> below:
> http://activemq.2283324.n4.nabble.com/Queue-Size-with-STOMP-tp4679543p4679610.html
> To start a new topic under ActiveMQ - Dev, email
> ml-node+s2283324n2368404h72@n4.nabble.com
> To unsubscribe from ActiveMQ - Dev, visit
> http://activemq.2283324.n4.nabble.com/template/NamlServlet.jtp?macro=unsubscribe_by_code&node=2368404&code=YXJ0QGFydG5hc2VlZi5jb218MjM2ODQwNHwtMjA1NDcyNjY5MQ==






--
View this message in context: http://activemq.2283324.n4.nabble.com/Queue-Size-with-STOMP-tp4679543p4679613.html
Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message