activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aleksandar Stojadinovic (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMQ-5040) This issue still exists with the 5.9.0 version and the Eclipse Paho Client.
Date Tue, 11 Feb 2014 10:25:20 GMT
Aleksandar Stojadinovic created AMQ-5040:
--------------------------------------------

             Summary: This issue still exists with the 5.9.0 version and the Eclipse Paho
Client. 
                 Key: AMQ-5040
                 URL: https://issues.apache.org/jira/browse/AMQ-5040
             Project: ActiveMQ
          Issue Type: Bug
          Components: MQTT
    Affects Versions: 5.7.0
         Environment: Win 2008
            Reporter: Aleksandar Stojadinovic
             Fix For: 5.9.0


I built client that is connecting to Apache MQ set for mqtt. 

Now on first try client establishes the connection with client id = test1, sends message and
closes connection

         if(!client.isConnected()){
			client.connect(conOpt);
        }
        MqttTopic topic = client.getTopic(topicName);

        MqttMessage message = new MqttMessage(payload);
    	message.setQos(qos);
    	MqttDeliveryToken token = topic.publish(message);
    	token.waitForCompletion();
    	client.disconnect();


Then when again I run client it fails on connect ... I can see log in apache mq log:

 WARN | Transport Connection to: tcp://127.0.0.1:57354 failed: java.io.IOExcepti
on: Broker: localhost - Client: test1 already connected from tcp://127.0.0.1:57
330

in connection options I have set only setCleanSession(true). Paho client I have downloaded
from site as stable version.

I have first tried to raise an issue with the Eclipse Paho project (https://bugs.eclipse.org/bugs/show_bug.cgi?id=408105)
and after investigation their team came to conclusion that this is not on clinet side



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message