activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arthur Naseef (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMQ-4970) Deletion of a queue inaffective across broker restart
Date Sat, 18 Jan 2014 06:08:19 GMT

    [ https://issues.apache.org/jira/browse/AMQ-4970?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13875562#comment-13875562
] 

Arthur Naseef commented on AMQ-4970:
------------------------------------

Last of the small updates.

After pulling down the head and testing, the test passes.  I'm trying to track down the change
that appears to fix the problem to understand why it makes the test pass - in case it doesn't
truly fix the root cause.

> Deletion of a queue inaffective across broker restart
> -----------------------------------------------------
>
>                 Key: AMQ-4970
>                 URL: https://issues.apache.org/jira/browse/AMQ-4970
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Broker
>    Affects Versions: 5.9.0
>         Environment: mac osx/mavericks
>            Reporter: Arthur Naseef
>         Attachments: AMQ4970Test.zip, AMQ4970Test.zip, AMQ4970Test.zip
>
>
> Deleting a queue, it is revived from persistent store after a broker restart.  The following
steps reproduce the problem:
> * Create a queue (confirmed using the REST client I/F)
> * Shutdown the broker
> * Startup the broker
> * Confirm queue still exists via the hawtio ui (correct operation so far)
> * Delete the queue
> * Confirm queue removed via the hawtio ui
> * Shutdown the broker
> * Startup the broker
> * Confirm queue was not recreated via hawtio ui (failed: queue still exists)



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message