activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gary Tully (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMQ-4961) leveldbjni platform jars not included in binary release
Date Mon, 06 Jan 2014 15:34:51 GMT

    [ https://issues.apache.org/jira/browse/AMQ-4961?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13863048#comment-13863048
] 

Gary Tully commented on AMQ-4961:
---------------------------------

The removal is intentional see: https://issues.apache.org/jira/browse/AMQ-4599
For the 1.7 jni deps - maybe the uber jar will suffice:
http://repo1.maven.org/maven2/org/fusesource/leveldbjni/leveldbjni-all/1.7/

> leveldbjni platform jars not included in binary release
> -------------------------------------------------------
>
>                 Key: AMQ-4961
>                 URL: https://issues.apache.org/jira/browse/AMQ-4961
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: activemq-leveldb-store
>    Affects Versions: 5.9.0
>         Environment: all
>            Reporter: Ulrich Romahn
>            Priority: Critical
>
> It appears that the binary release of ActiveMQ 5.9.0 is missing all the platform-specific
leveldbjni files in lib/optional. Those files are all present in ActiveMQ 5.8.0 binary release.
> Reason: AMQ 5.9.0 depends on leveldbjni-1.7.0 which would then also require all the platform-specific
jni jars of version 1.7.0. Unfortunately it appears that all public maven repos (specifically
on repo1.maven.org) do not contain version 1.7 of those jars. The public maven repo contains
version 1.5 and then 1.8.
> This is not specific an issue of ActiveMQ, but I still wanted the ActiveMQ team make
aware of this issue.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message