activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMQ-3239) Jboss blocked in startup when messages are in the que
Date Sat, 02 Nov 2013 20:57:19 GMT

    [ https://issues.apache.org/jira/browse/AMQ-3239?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13812166#comment-13812166
] 

Claus Ibsen commented on AMQ-3239:
----------------------------------

The JCA RAR has been improved a lot in the 5.9 release and verified working in JBoss AS etc.

> Jboss blocked in startup when messages are in the que
> -----------------------------------------------------
>
>                 Key: AMQ-3239
>                 URL: https://issues.apache.org/jira/browse/AMQ-3239
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Connector
>    Affects Versions: 5.4.2
>         Environment: - Jboss 5.1.0 GA
> - Activemq 5.4.2
>            Reporter: Mahmoud maalej
>             Fix For: 5.9.0
>
>
> Reproducing senario:
> 1- Start activemq server
> 2- With admin console send a message to testqueue (message is enqueued)
> 3- Deploy activemq-ra.rar connector
> 4- deploy an ear containing (an mdb to consume the message)  and a simple application
> 5- start jboss
> Always Jboss startup block after INFO  [ra.ActiveMQEndpointWorker] Successfully established
connection to broker [tcp://localhost:61616] and can't continue deployment of the ear which
contain the mdb consumer
> Is there a specific config to do, to let activemq-ra.rar deployed without trying to send
the pending message untill the server starup and that the mdb beying ready to consume it.




--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message