activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Remo Gloor (JIRA)" <jira+amq...@apache.org>
Subject [jira] [Updated] (AMQNET-450) NetTxTransaction replay is incorrect when using Failover Transport
Date Tue, 15 Oct 2013 06:40:42 GMT

     [ https://issues.apache.org/jira/browse/AMQNET-450?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Remo Gloor updated AMQNET-450:
------------------------------

          Component/s: NMS
                       ActiveMQ
    Affects Version/s: 1.6.0
        Fix Version/s: 1.6.1

> NetTxTransaction replay is incorrect when using Failover Transport
> ------------------------------------------------------------------
>
>                 Key: AMQNET-450
>                 URL: https://issues.apache.org/jira/browse/AMQNET-450
>             Project: ActiveMQ .Net
>          Issue Type: Bug
>          Components: ActiveMQ, NMS
>    Affects Versions: 1.6.0
>            Reporter: Remo Gloor
>            Assignee: Jim Gomes
>             Fix For: 1.6.1
>
>         Attachments: TransactionState.cs.patch
>
>
> TransactionState.AddCommand must clone the operation because TransactionInfo command
instances are reused (e.g. in NetTxTransactionContext.Prepare()). 
> If they are not cloned then the list will contain the second command twice and the no
instance of the first command because the first command is changed after added to the list
by the reassignment of some values when it is reused. This results in wrong replied messages
on reconnects.
> Another solution is not to reuse any command instance in the whole code.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message