activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "HellKnight (JIRA)" <jira+amq...@apache.org>
Subject [jira] [Created] (AMQNET-447) Individual Acknowledgement seems not working in NMS
Date Tue, 08 Oct 2013 01:09:42 GMT
HellKnight created AMQNET-447:
---------------------------------

             Summary: Individual Acknowledgement seems not working in NMS
                 Key: AMQNET-447
                 URL: https://issues.apache.org/jira/browse/AMQNET-447
             Project: ActiveMQ .Net
          Issue Type: Test
          Components: ActiveMQ, NMS
    Affects Versions: 1.6.0
         Environment: windows xp sp2 
visual studio 2010 sp1
.NET 4.0 
JavaSE Runtime Envrionment build 1.7.0_17-b02
ActiveMQ 5.8.0 running under RedHat 6.3
NMS 1.6.0
            Reporter: HellKnight
            Assignee: Jim Gomes


I create a simple unit test to show my problem in VS2010 , coded in c#.
The idea of my test is as follow :
1. Send some message to the broker by web console.
2. Start a durable subscriber , and receive the test messages.Then call message.acknowledge()
on the last message received.
3. Close the connection of the durable subscriber and start listening again.
    the session is using individual ack mode. Since the individual ack mode acknowledges each
message individually, I would expect that only the last message is acked , so after restart
the subscriber, the test messages except the last one should be received again. However, the
fact is every message is acked and 
none test message is received the second time. 
    Generally speaking, My unit test compare the number of message received before ack the
last message and after ack the last message. What I am expecting is the second time I will
receive one less message but the fact is I receive 0 message.




--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message