activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Libucha <mlibu...@gmail.com>
Subject Re: power linux activemq-cpp
Date Mon, 28 Oct 2013 13:56:04 GMT
Thought I would follow up here with what we found using activemq-cpp on
PowerLinux, versions 3.6 and 3.8 (so probably 3.7 as well).

We got it working by setting wireFormat.maxInactivityDuration=0 (on the
broker side).

Also, the seg faults I mentioned were *not* due to the activemq-cpp code.
Our problem was just the inability to keep an idle connect alive.

Thanks,

Mark



On Thu, Oct 17, 2013 at 5:36 PM, Mark Libucha <mlibucha@chiliad.com> wrote:

> Hi folks,
>
> New here. If this is the wrong place for questions about activemq-cpp,
> please accept my apologies. And redirect me, please?
>
> Trying to get activemq-cpp running on PowerLinux. It builds OK, but can't
> sustain connect to the broker. 64bit, it actually seg faults. 32bit there
> isn't but it still can't hold the connection.
>
> (Runs fine on RedHat, AIX, so the app is solid.)
>
> A couple of the unit tests fail, output below. Thanks for any help or
> suggestions.
>
> Mark
>
> !!!FAILURES!!!
> Test Results:
> Run:  103   Failures: 2   Errors: 0
>
>
> 1) test:
>
> N8activemq4test8openwire30OpenwireEnhancedConnectionTestE::testDestinationSource
> (F) line: 237 activemq/test/openwire/OpenwireEnhancedConnectionTest.cpp
> equality assertion failed
> - Expected: 0
> - Actual  : 94
>
>
> 2) test:
>
> N8activemq4test8openwire30OpenwireEnhancedConnectionTestE::testDestinationSourceGetters
> (F) line: 171 activemq/test/openwire/OpenwireEnhancedConnectionTest.cpp
> equality assertion failed
> - Expected: 1
> - Actual  : 95
> - Should be one Queue
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message