activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gary Tully (JIRA)" <>
Subject [jira] [Resolved] (AMQ-4347) Rename lockKeepAlivePeriod and lockAcquireSleepInterval for more intuition
Date Mon, 23 Sep 2013 10:17:04 GMT


Gary Tully resolved AMQ-4347.

    Resolution: Won't Fix

peeked at this, and I am not sure it is worth introducing new variables to the lease locker.

If the 'lock' term is replaced with a 'lease' term I think they make some sense. granted the
names reflect more the implementation rather than the intent which is not ideal but the implementation
is shared with all lockers so there is some consistency.
> Rename lockKeepAlivePeriod and lockAcquireSleepInterval for more intuition
> --------------------------------------------------------------------------
>                 Key: AMQ-4347
>                 URL:
>             Project: ActiveMQ
>          Issue Type: Improvement
>          Components: Message Store
>    Affects Versions: 5.7.0, 5.8.0
>            Reporter: SuoNayi
>            Assignee: Gary Tully
>            Priority: Minor
>             Fix For: 5.9.0
> For lease database locker the lockKeepAlivePeriod property is the peroid to renew the
lease and lockAcquireSleepInterval is the amount for lease extension.Renaming them to leaseRenewPeroid
and leaseDuration respectively brings more intuition and readability.
> Besides, leaseDuration should be greater than leaseRenewPeroid to avoid unnecessary master/slave
> The users should be aware of unproper configuration via warning log.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

View raw message