activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Danilo Moret (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMQ-4686) Message browsing denied for stomp protocol 1.2
Date Tue, 20 Aug 2013 15:04:51 GMT
Danilo Moret created AMQ-4686:
---------------------------------

             Summary: Message browsing denied for stomp protocol 1.2
                 Key: AMQ-4686
                 URL: https://issues.apache.org/jira/browse/AMQ-4686
             Project: ActiveMQ
          Issue Type: Bug
          Components: Transport
    Affects Versions: 5.8.0, 5.7.0, 5.6.0
         Environment: Tested on MacOS 10.8.4, Apache ActiveMQ 5.8.0 installed via brew, stompgem
1.2.14 installed via gem install, Java(TM) SE Runtime Environment (build 1.6.0_51-b11-457-11M4509)
            Reporter: Danilo Moret
            Priority: Minor


Hello.

Connected to the broker and successfully negotiated 1.2 as the protocol version with the CONNECT
frames. When sending the header browser:true within a SUBSCRIBE frame the broker logs the
exception "org.apache.activemq.transport.stomp.ProtocolException: Queue Browser feature only
valid for Stomp v1.1 clients!".

Checking file https://svn.apache.org/repos/asf/activemq/trunk/activemq-stomp/src/main/java/org/apache/activemq/transport/stomp/ProtocolConverter.java
, line 557, the exception is thrown if the protocol is not 1.1 only, not 1.1 or above. Confirmed
on the user list this seems to be a bug: http://activemq.2283324.n4.nabble.com/Message-browsing-with-Stomp-client-1-2-td4670514.html

Regards.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message