activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kurt Roekle (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMQ-4633) VirtualTopic consumer queue matching
Date Wed, 17 Jul 2013 18:37:47 GMT

    [ https://issues.apache.org/jira/browse/AMQ-4633?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13711434#comment-13711434
] 

Kurt Roekle commented on AMQ-4633:
----------------------------------

I have a little more information.  I've testing in 5.8.  The UI bug where it seemed to show
double the messages is now gone.  But I found an even more serious bug (in both 5.6 and 5.8).
 When you delete the second queue (the one with the extra period), it deletes the messages
from the first queue as well.  Also, after the deletion the first queue will not receive any
messages from the topic until the broker is restarted.  This caused us to lose 60k+ messages
over the last few days.

Sorry, I don't have time to learn the codebase and create a unittest.  
                
> VirtualTopic consumer queue matching
> ------------------------------------
>
>                 Key: AMQ-4633
>                 URL: https://issues.apache.org/jira/browse/AMQ-4633
>             Project: ActiveMQ
>          Issue Type: Bug
>    Affects Versions: 5.6.0, 5.8.0
>            Reporter: Kurt Roekle
>            Priority: Minor
>
> Using the default configuration for virtual topics, we are seeing some unexpected behavior
with how messages are being delivered to the consumer queues.
> We have a virtual topic setup named "VirtualTopic.zzzzzz.in".  We have one consumer queue
setup named "Consumer.b.VirtualTopic.zzzzzz.in".  We also have a queue setup named "Consumer.b.VirtualTopic.zzzzzz.in."
which we don't believe should be receiving messages. The second queue (the one with the extra
period) is receiving messages when placed in the topic.  Furthermore, when adding two messages
to the topic, the queues list web UI shows that two messages are in each queue, but when you
open up either queue in the web UI to see the messages, there appear to be double the messages
(4 in this case).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message