activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sumit Wattal (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMQ-4613) Not able to receive messages for a group in a queue
Date Tue, 02 Jul 2013 16:23:19 GMT
Sumit Wattal created AMQ-4613:
---------------------------------

             Summary: Not able to receive messages for a group in a queue
                 Key: AMQ-4613
                 URL: https://issues.apache.org/jira/browse/AMQ-4613
             Project: ActiveMQ
          Issue Type: Bug
          Components: JMX
    Affects Versions: 5.8.0
            Reporter: Sumit Wattal


I was testing a scenario where the JMSXGroupID property is set to 0 and 1 (two groups) for
TextMessage objects and pushed to a queue. The receiver creates a MessageConsumer with the
messageSelector as the "JMSXGroupID = 0" "JMSXGroupID = 0". 

While calling the receive the messageConsumer doesn't get back anything. I further investigated
and found that the messages were not getting enqueued to the MessageDispatchChannel object
in ActiveMQMessageConsumer. I have the same test case working for ActiveMQ 5.6. Digging further
I found that a MessageDispatch command was not being generated. Is this a configuration issue
on my end?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message