activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Posta <christian.po...@gmail.com>
Subject Re: wackiness in Apollo websockets tests
Date Wed, 10 Jul 2013 04:18:20 GMT
so never mind... when in doubt, 'mvn clean' it out...Intellij back on
track...


On Wed, Jul 10, 2013 at 12:04 AM, Christian Posta <christian.posta@gmail.com
> wrote:

> @Hiram
> You ever see this when running the websockets test in Intellij?
>
> stacktrace | ERROR | java.lang.IllegalArgumentException: Unknown transport
> bind uri: ws://0.0.0.0:0
> java.lang.IllegalArgumentException: Unknown transport bind uri: ws://
> 0.0.0.0:0
> at
> org.apache.activemq.apollo.broker.transport.TransportFactory.bind(TransportFactory.java:59)
>  at
> org.apache.activemq.apollo.broker.AcceptingConnector._start(Connector.scala:246)
> at
> org.apache.activemq.apollo.util.BaseService$$anonfun$start_task$1$1.do_start$1(BaseService.scala:88)
>  at
> org.apache.activemq.apollo.util.BaseService$$anonfun$start_task$1$1.apply$mcV$sp(BaseService.scala:104)
> at org.fusesource.hawtdispatch.package$$anon$4.run(hawtdispatch.scala:357)
>  at
> org.fusesource.hawtdispatch.internal.SerialDispatchQueue.run(SerialDispatchQueue.java:100)
> at
> org.fusesource.hawtdispatch.internal.pool.SimpleThread.run(SimpleThread.java:77)
>
>
> The transport-factory.index has the WS factory in correctly... but when
> the ClassFinder tries to load it, it cannot... so it never gets registered
> as a valid transport option.. There should be no reason it cannot find in
> on CP.. unless it's some wackiness with scala+Intellij... long shot to see
> if you have seen this...
>
> --
> *Christian Posta*
> http://www.christianposta.com/blog
> twitter: @christianposta
>



-- 
*Christian Posta*
http://www.christianposta.com/blog
twitter: @christianposta

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message