activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Timothy Bish (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMQ-4543) Client already connected error when connecting to MQTT server a second time
Date Sat, 18 May 2013 10:35:16 GMT

    [ https://issues.apache.org/jira/browse/AMQ-4543?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13661330#comment-13661330
] 

Timothy Bish commented on AMQ-4543:
-----------------------------------

Have you tried a later release such a v5.8.0 or a SNAPSHOT of 5.9?  There's already bee a
lot of MQTT fixes since 5.7 so this is possibly already taken care of. 
                
> Client already connected error when connecting to MQTT server a second time 
> ----------------------------------------------------------------------------
>
>                 Key: AMQ-4543
>                 URL: https://issues.apache.org/jira/browse/AMQ-4543
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: MQTT
>    Affects Versions: 5.7.0
>         Environment: Win 2008
>            Reporter: Dorde Popovic
>
> I built client that is connecting to Apache MQ set for mqtt. 
> Now on first try client establishes the connection with client id = test1, sends message
and closes connection
>          if(!client.isConnected()){
> 			client.connect(conOpt);
>         }
>         MqttTopic topic = client.getTopic(topicName);
>         MqttMessage message = new MqttMessage(payload);
>     	message.setQos(qos);
>     	MqttDeliveryToken token = topic.publish(message);
>     	token.waitForCompletion();
>     	client.disconnect();
> Then when again I run client it fails on connect ... I can see log in apache mq log:
>  WARN | Transport Connection to: tcp://127.0.0.1:57354 failed: java.io.IOExcepti
> on: Broker: localhost - Client: test1 already connected from tcp://127.0.0.1:57
> 330
> in connection options I have set only setCleanSession(true). Paho client I have downloaded
from site as stable version.
> I have first tried to raise an issue with the Eclipse Paho project (https://bugs.eclipse.org/bugs/show_bug.cgi?id=408105)
and after investigation their team came to conclusion that this is not on clinet side

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message