activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From SuoNayi <suonayi2...@163.com>
Subject Re:Consumer listeners with prefetch=0, polling creates very high and increasing "Enqueues" in console
Date Fri, 19 Apr 2013 07:14:29 GMT
I believe this is not a expected behavior.
Only enqueue count increases while no dequeue and dispatch...




At 2013-04-19 00:01:18,Rich1 <rich@bdgitc.com> wrote:
>Using Spring-configured ActiveMQ, with a listener configured with a
>prefetch=0 connectionFactory and 5-5 concurrency, we're seeing the listeners
>apparently poll for new messages instead of the broker pushing messages, as
>expected.
>
>However, in the ActiveMQ web console for the "Active Listeners" of our
>queue, I see that the "Enqueues" column count continually rises at a rapid
>rate (about 1 every second). Is this normal behavior? Is this just
>reflecting each poll of the listeners for new messages, now that we have
>prefetch=0?  It just seems a bit strange that the queues are showing an
>increasing Enqueue count when there's no actual messages they're working.
>Was also wondering if there's a way to throttle the poll frequency, or have
>some delay before each consumer polls the broker for new messages.
>
>Pic of the console, showing the ever-increasing Enqueue count of each
>consumer with prefetch=0, even when there's no messages to work:
>
><http://activemq.2283324.n4.nabble.com/file/n4666021/enqueues.png> 
>
>
>
>
>
>
>
>--
>View this message in context: http://activemq.2283324.n4.nabble.com/Consumer-listeners-with-prefetch-0-polling-creates-very-high-and-increasing-Enqueues-in-console-tp4666021.html
>Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message