activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bhanu (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMQ-4383) ActiveMQ dependency not present in central maven repository ??
Date Mon, 18 Mar 2013 10:26:15 GMT
Bhanu created AMQ-4383:
--------------------------

             Summary: ActiveMQ dependency not present in central maven repository ??
                 Key: AMQ-4383
                 URL: https://issues.apache.org/jira/browse/AMQ-4383
             Project: ActiveMQ
          Issue Type: Bug
          Components: Broker
    Affects Versions: 5.8.0
         Environment: Linux
            Reporter: Bhanu


We're facing issues while trying to upgrade to ActiveMQ v5.8. The maven build is failing with
the following error:-

        <dependency>
            <groupId>org.apache.activemq</groupId>
            <artifactId>activemq-all</artifactId>
            <version>5.8.0</version>
         <exclusions>

mvn package -Dmaven.test.skip=true
[INFO] Scanning for projects...
[INFO] ------------------------------------------------------------------------
[INFO] Building common
[INFO]    task-segment: [package]
[INFO] ------------------------------------------------------------------------
[INFO] [resources:resources]
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] skip non existing resourceDirectory /prod/desflow-qa/dflowdev/test/desflow/common/src/main/resources
Downloading: http://maven/deshaw/org/apache/qpid/proton-jms/0.3.0-fuse-2/proton-jms-0.3.0-fuse-2.pom
Downloading: http://maven/deshaw/org/apache/qpid/proton-jms/0.3.0-fuse-2/proton-jms-0.3.0-fuse-2.pom
Downloading: http://maven/deshaw/org/apache/qpid/proton-jms/0.3.0-fuse-2/proton-jms-0.3.0-fuse-2.pom
Downloading: http://maven/deshaw/org/apache/qpid/proton-jms/0.3.0-fuse-2/proton-jms-0.3.0-fuse-2.jar
Downloading: http://maven/deshaw/org/apache/qpid/proton-jms/0.3.0-fuse-2/proton-jms-0.3.0-fuse-2.jar
Downloading: http://maven/deshaw/org/apache/qpid/proton-jms/0.3.0-fuse-2/proton-jms-0.3.0-fuse-2.jar
Downloading: http://maven/deshaw/org/apache/qpid/proton-jms/0.3.0-fuse-2/proton-jms-0.3.0-fuse-2.jar
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Failed to resolve artifact.

Missing:
----------
1) org.apache.qpid:proton-jms:jar:0.3.0-fuse-2

  Try downloading the file manually from the project website.

  Then, install it using the command:
      mvn install:install-file -DgroupId=org.apache.qpid -DartifactId=proton-jms -Dversion=0.3.0-fuse-2
-Dpackaging=jar -Dfile=/path/to/file


Is something broken here ?

Thanks,
Bhanu

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message