activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "SuoNayi (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMQ-4347) Rename lockKeepAlivePeriod and lockAcquireSleepInterval for more intuition
Date Tue, 26 Feb 2013 08:34:15 GMT

     [ https://issues.apache.org/jira/browse/AMQ-4347?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

SuoNayi updated AMQ-4347:
-------------------------

    Description: 
For lease database locker the lockKeepAlivePeriod property is the peroid to renew the lease
and lockAcquireSleepInterval is the amount for lease extension.Renaming them to leaseRenewPeroid
and leaseDuration respectively brings more intuition and readability.
Besides, leaseRenewPeroid  should be greater than leaseDuration to avoid unnecessary master/slave
switching. 

  was:For lease database locker the lockKeepAlivePeriod property is the peroid to renew the
lease and lockAcquireSleepInterval is the amount for lease extension.Renaming them to leaseRenewPeroid
and leaseDuration respectively brings more intuition and readability.

    
> Rename lockKeepAlivePeriod and lockAcquireSleepInterval for more intuition
> --------------------------------------------------------------------------
>
>                 Key: AMQ-4347
>                 URL: https://issues.apache.org/jira/browse/AMQ-4347
>             Project: ActiveMQ
>          Issue Type: Improvement
>          Components: Message Store
>    Affects Versions: 5.7.0, 5.8.0
>            Reporter: SuoNayi
>            Priority: Minor
>             Fix For: 5.9.0
>
>
> For lease database locker the lockKeepAlivePeriod property is the peroid to renew the
lease and lockAcquireSleepInterval is the amount for lease extension.Renaming them to leaseRenewPeroid
and leaseDuration respectively brings more intuition and readability.
> Besides, leaseRenewPeroid  should be greater than leaseDuration to avoid unnecessary
master/slave switching. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message