activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Raul Kripalani (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMQ-4229) activemq-web-console unusable in OSGi due to massive exports
Date Tue, 18 Dec 2012 00:44:12 GMT

     [ https://issues.apache.org/jira/browse/AMQ-4229?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Raul Kripalani updated AMQ-4229:
--------------------------------

    Description: 
{{activemq-web-console}} is unusable in an OSGi environment because it embeds all of AMQ classes
inside it and exports them to the OSGi container. Thus, classloading conflicts start to appear
in bundles importing org.apache.activemq packages.

smx@root> list | grep activemq
[ 198] [Active     ] [            ] [       ] [   50] activemq-web-console (5.7.0)
smx@root> exports 198
    ID Packages                                
   198 org.apache.activemq.jaas; version="5.7.0"
   198 org.apache.activemq.memory.list; version="5.7.0"
   198 org.apache.activemq.transport.discovery.simple; version="5.7.0"
   198 org.apache.activemq.transport.xmpp; version="5.7.0"
   198 org.apache.activemq.advisory; version="5.7.0"
   198 org.apache.activemq.broker.jmx; version="5.7.0"
   198 org.apache.activemq.broker; version="5.7.0"
   198 org.apache.activemq.blob; version="5.7.0"
   198 org.apache.activemq.usage; version="5.7.0"
   198 org.apache.activemq.transport.discovery.zeroconf; version="5.7.0"
   198 org.apache.activemq.transport.stomp; version="5.7.0"
   198 org.apache.activemq.transport.mqtt; version="5.7.0"
   198 org.apache.activemq.transport.peer; version="5.7.0"
   198 org.apache.activemq.transport.failover; version="5.7.0"
   198 org.apache.activemq.broker.region.group; version="5.7.0"
   198 org.apache.activemq.transport; version="5.7.0"
   198 org.apache.activemq.kaha.impl.index; version="5.7.0"
   198 org.apache.activemq.store.memory; version="5.7.0"
   198 org.apache.activemq.console.command.store.amq.reader; version="5.7.0"
   198 org.apache.activemq.broker.region; version="5.7.0"
   198 org.apache.activemq.store.jdbc.adapter; version="5.7.0"
   198 org.apache.activemq.transport.reliable; version="5.7.0"
   198 org.apache.activemq.transport.discovery.multicast; version="5.7.0"
   198 org.apache.activemq.transport.tcp; version="5.7.0"
   198 org.apache.activemq.kaha.impl.container; version="5.7.0"
   198 org.apache.activemq.state; version="5.7.0"
   198 org.apache.activemq.broker.scheduler; version="5.7.0"
   198 org.apache.activemq.console.filter; version="5.7.0"
   198 org.apache.activemq.management; version="5.7.0"
   198 org.apache.activemq.transport.mock; version="5.7.0"
   198 org.apache.activemq.transport.vm; version="5.7.0"
   198 org.apache.activemq.xbean; version="5.7.0"
   198 org.apache.activemq.kaha.impl; version="5.7.0"
   198 org.apache.activemq.camel; version="5.7.0"
   198 org.apache.activemq.web.config; version="5.7.0"
   198 org.apache.activemq.openwire.v1; version="5.7.0"
   198 org.apache.activemq.openwire.v2; version="5.7.0"
   198 org.apache.activemq.openwire.v3; version="5.7.0"
   198 org.apache.activemq.openwire.v4; version="5.7.0"
...

  was:
{{activemq-web-console}} is unusable in an OSGi environment because it embeds all of AMQ classes
inside it and exports them to the OSGi container.

smx@root> list | grep activemq
[ 198] [Active     ] [            ] [       ] [   50] activemq-web-console (5.7.0)
smx@root> exports 198
    ID Packages                                
   198 org.apache.activemq.jaas; version="5.7.0"
   198 org.apache.activemq.memory.list; version="5.7.0"
   198 org.apache.activemq.transport.discovery.simple; version="5.7.0"
   198 org.apache.activemq.transport.xmpp; version="5.7.0"
   198 org.apache.activemq.advisory; version="5.7.0"
   198 org.apache.activemq.broker.jmx; version="5.7.0"
   198 org.apache.activemq.broker; version="5.7.0"
   198 org.apache.activemq.blob; version="5.7.0"
   198 org.apache.activemq.usage; version="5.7.0"
   198 org.apache.activemq.transport.discovery.zeroconf; version="5.7.0"
   198 org.apache.activemq.transport.stomp; version="5.7.0"
   198 org.apache.activemq.transport.mqtt; version="5.7.0"
   198 org.apache.activemq.transport.peer; version="5.7.0"
   198 org.apache.activemq.transport.failover; version="5.7.0"
   198 org.apache.activemq.broker.region.group; version="5.7.0"
   198 org.apache.activemq.transport; version="5.7.0"
   198 org.apache.activemq.kaha.impl.index; version="5.7.0"
   198 org.apache.activemq.store.memory; version="5.7.0"
   198 org.apache.activemq.console.command.store.amq.reader; version="5.7.0"
   198 org.apache.activemq.broker.region; version="5.7.0"
   198 org.apache.activemq.store.jdbc.adapter; version="5.7.0"
   198 org.apache.activemq.transport.reliable; version="5.7.0"
   198 org.apache.activemq.transport.discovery.multicast; version="5.7.0"
   198 org.apache.activemq.transport.tcp; version="5.7.0"
   198 org.apache.activemq.kaha.impl.container; version="5.7.0"
   198 org.apache.activemq.state; version="5.7.0"
   198 org.apache.activemq.broker.scheduler; version="5.7.0"
   198 org.apache.activemq.console.filter; version="5.7.0"
   198 org.apache.activemq.management; version="5.7.0"
   198 org.apache.activemq.transport.mock; version="5.7.0"
   198 org.apache.activemq.transport.vm; version="5.7.0"
   198 org.apache.activemq.xbean; version="5.7.0"
   198 org.apache.activemq.kaha.impl; version="5.7.0"
   198 org.apache.activemq.camel; version="5.7.0"
   198 org.apache.activemq.web.config; version="5.7.0"
   198 org.apache.activemq.openwire.v1; version="5.7.0"
   198 org.apache.activemq.openwire.v2; version="5.7.0"
   198 org.apache.activemq.openwire.v3; version="5.7.0"
   198 org.apache.activemq.openwire.v4; version="5.7.0"
...

    
> activemq-web-console unusable in OSGi due to massive exports
> ------------------------------------------------------------
>
>                 Key: AMQ-4229
>                 URL: https://issues.apache.org/jira/browse/AMQ-4229
>             Project: ActiveMQ
>          Issue Type: Bug
>    Affects Versions: 5.7.0
>            Reporter: Raul Kripalani
>            Priority: Critical
>
> {{activemq-web-console}} is unusable in an OSGi environment because it embeds all of
AMQ classes inside it and exports them to the OSGi container. Thus, classloading conflicts
start to appear in bundles importing org.apache.activemq packages.
> smx@root> list | grep activemq
> [ 198] [Active     ] [            ] [       ] [   50] activemq-web-console (5.7.0)
> smx@root> exports 198
>     ID Packages                                
>    198 org.apache.activemq.jaas; version="5.7.0"
>    198 org.apache.activemq.memory.list; version="5.7.0"
>    198 org.apache.activemq.transport.discovery.simple; version="5.7.0"
>    198 org.apache.activemq.transport.xmpp; version="5.7.0"
>    198 org.apache.activemq.advisory; version="5.7.0"
>    198 org.apache.activemq.broker.jmx; version="5.7.0"
>    198 org.apache.activemq.broker; version="5.7.0"
>    198 org.apache.activemq.blob; version="5.7.0"
>    198 org.apache.activemq.usage; version="5.7.0"
>    198 org.apache.activemq.transport.discovery.zeroconf; version="5.7.0"
>    198 org.apache.activemq.transport.stomp; version="5.7.0"
>    198 org.apache.activemq.transport.mqtt; version="5.7.0"
>    198 org.apache.activemq.transport.peer; version="5.7.0"
>    198 org.apache.activemq.transport.failover; version="5.7.0"
>    198 org.apache.activemq.broker.region.group; version="5.7.0"
>    198 org.apache.activemq.transport; version="5.7.0"
>    198 org.apache.activemq.kaha.impl.index; version="5.7.0"
>    198 org.apache.activemq.store.memory; version="5.7.0"
>    198 org.apache.activemq.console.command.store.amq.reader; version="5.7.0"
>    198 org.apache.activemq.broker.region; version="5.7.0"
>    198 org.apache.activemq.store.jdbc.adapter; version="5.7.0"
>    198 org.apache.activemq.transport.reliable; version="5.7.0"
>    198 org.apache.activemq.transport.discovery.multicast; version="5.7.0"
>    198 org.apache.activemq.transport.tcp; version="5.7.0"
>    198 org.apache.activemq.kaha.impl.container; version="5.7.0"
>    198 org.apache.activemq.state; version="5.7.0"
>    198 org.apache.activemq.broker.scheduler; version="5.7.0"
>    198 org.apache.activemq.console.filter; version="5.7.0"
>    198 org.apache.activemq.management; version="5.7.0"
>    198 org.apache.activemq.transport.mock; version="5.7.0"
>    198 org.apache.activemq.transport.vm; version="5.7.0"
>    198 org.apache.activemq.xbean; version="5.7.0"
>    198 org.apache.activemq.kaha.impl; version="5.7.0"
>    198 org.apache.activemq.camel; version="5.7.0"
>    198 org.apache.activemq.web.config; version="5.7.0"
>    198 org.apache.activemq.openwire.v1; version="5.7.0"
>    198 org.apache.activemq.openwire.v2; version="5.7.0"
>    198 org.apache.activemq.openwire.v3; version="5.7.0"
>    198 org.apache.activemq.openwire.v4; version="5.7.0"
> ...

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message