activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Timothy Bish (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (AMQ-3584) ActiveMQ Performance module is not useable per instructions
Date Wed, 05 Dec 2012 20:05:58 GMT

     [ https://issues.apache.org/jira/browse/AMQ-3584?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Timothy Bish resolved AMQ-3584.
-------------------------------

    Resolution: Fixed

updated the pom for the smaple project to reflect new versions and the future v5.8.0 plugin
name changes.
                
> ActiveMQ Performance module is not useable per instructions
> -----------------------------------------------------------
>
>                 Key: AMQ-3584
>                 URL: https://issues.apache.org/jira/browse/AMQ-3584
>             Project: ActiveMQ
>          Issue Type: Bug
>            Reporter: Jason Dillon
>
> I was looking at http://activemq.apache.org/activemq-performance-module-users-manual.html
to see how well (or poorly) the http transport was over the tcp transport and I've run into
some issues just following the instructions.
> svn co http://svn.apache.org/repos/asf/activemq/sandbox/activemq-perftest/
> cd activemq-perftest
> mvn activemq-perf:broker -Durl=broker:tcp://localhost:61616
> {noformat}
> [INFO] Scanning for projects...
> [ERROR] The build could not read 1 project -> [Help 1]
> [ERROR]   
> [ERROR]   The project org.apache.activemq:activemq-perftest:5.2-SNAPSHOT (/Users/jason/ws/reference/activemq-perftest/pom.xml)
has 1 error
> [ERROR]     Non-resolvable parent POM: Could not find artifact org.apache.activemq:activemq-parent:pom:5.2-SNAPSHOT
and 'parent.relativePath' points at wrong local POM @ line 22, column 13 -> [Help 2]
> [ERROR] 
> [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR] 
> [ERROR] For more information about the errors and possible solutions, please read the
following articles:
> [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
> [ERROR] [Help 2] http://cwiki.apache.org/confluence/display/MAVEN/UnresolvableModelException
> {noformat}
> If I change the version to 5.5.1:
> {noformat}
> Index: pom.xml
> ===================================================================
> --- pom.xml	(revision 1199413)
> +++ pom.xml	(working copy)
> @@ -22,7 +22,7 @@
>     <parent>
>         <artifactId>activemq-parent</artifactId>
>         <groupId>org.apache.activemq</groupId>
> -        <version>5.2-SNAPSHOT</version>
> +        <version>5.5.1</version>
>     </parent>
>     <artifactId>activemq-perftest</artifactId>
> {noformat}
> mvn activemq-perf:broker -Durl=broker:tcp://localhost:61616
> {noformat}
> [INFO] Scanning for projects...
> [WARNING] 
> [WARNING] Some problems were encountered while building the effective model for org.apache.activemq:activemq-perftest:jar:5.5.1
> [WARNING] 'build.plugins.plugin.version' for org.apache.activemq.tooling:maven-activemq-perf-plugin
is missing. @ line 35, column 21
> [WARNING] 'build.plugins.plugin.version' for org.apache.activemq.tooling:maven-activemq-memtest-plugin
is missing. @ line 39, column 21
> [WARNING] 
> [WARNING] It is highly recommended to fix these problems because they threaten the stability
of your build.
> [WARNING] 
> [WARNING] For this reason, future Maven versions might no longer support building such
malformed projects.
> [WARNING] 
> [INFO]                                                                         
> [INFO] ------------------------------------------------------------------------
> [INFO] Building ActiveMQ :: Performance Test 5.5.1
> [INFO] ------------------------------------------------------------------------
> [INFO] 
> [INFO] --- maven-activemq-perf-plugin:5.5.1:broker (default-cli) @ activemq-perftest
---
> Java Runtime: Apple Inc. 1.6.0_26 /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home
>  Heap sizes: current=83008k  free=60712k  max=517760k
>    JVM args: -Xmx512m -XX:MaxPermSize=128m -Dclassworlds.conf=/Users/jason/tools/maven/maven3/bin/m2.conf
-Dmaven.home=/Users/jason/tools/maven/maven3
> ACTIVEMQ_HOME: /Users/jason/.m2/repository/org/apache/activemq/activemq-console
> ACTIVEMQ_BASE: /Users/jason/.m2/repository/org/apache/activemq/activemq-console
> Loading message broker from: broker:tcp://localhost:61616
> SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
> SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
> Failed to execute main task. Reason: java.lang.NoClassDefFoundError: org/slf4j/impl/StaticLoggerBinder
> {noformat}
> So I configured logback & upgraded slf4j:
> {noformat}
> Index: pom.xml
> ===================================================================
> --- pom.xml	(revision 1199413)
> +++ pom.xml	(working copy)
> @@ -22,7 +22,7 @@
>     <parent>
>         <artifactId>activemq-parent</artifactId>
>         <groupId>org.apache.activemq</groupId>
> -        <version>5.2-SNAPSHOT</version>
> +        <version>5.5.1</version>
>     </parent>
>     <artifactId>activemq-perftest</artifactId>
> @@ -35,6 +35,18 @@
>             <plugin>
>                 <groupId>org.apache.activemq.tooling</groupId>
>                 <artifactId>maven-activemq-perf-plugin</artifactId>
> +                <dependencies>
> +                    <dependency>
> +                        <groupId>org.slf4j</groupId>
> +                        <artifactId>slf4j-api</artifactId>
> +                        <version>1.6.2</version>
> +                    </dependency>
> +                    <dependency>
> +                        <groupId>ch.qos.logback</groupId>
> +                        <artifactId>logback-classic</artifactId>
> +                        <version>1.0.0</version>
> +                    </dependency>
> +                </dependencies>
>             </plugin>
>             <plugin>
>                 <groupId>org.apache.activemq.tooling</groupId>
> {noformat}
> ... and now it seems to function.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message