activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jessy (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMQ-4193) Unable to load custom properties from credentials.properties file located in conf folder of ActiveMQ installation directory
Date Wed, 05 Dec 2012 09:10:58 GMT

    [ https://issues.apache.org/jira/browse/AMQ-4193?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13510368#comment-13510368
] 

Jessy commented on AMQ-4193:
----------------------------


I got your point that having multiple brokers is causing the issue when I tried to import
one xml into another one. As you know, In activemq installation directory,there is a separate
activemq-jdbc.xml for custorm persistance support. 
When we startup activemq, basically this is not the xml we will run.we would run the activemq.xml
which has default kaha database persistance and not custom shared datasource.

So , I tried to import activemq-jdbc.xml into  activemq.xml, commenting out the duplicate
entries like <transportConnectors>.However, now that i noticed that broker property
is being present in both the xml,which u suggest is problematic.

So, do we need to add the additional properties[say 
        <destinationPolicy>,   <systemUsage>
] present in activemq.xml into activemq-jdbc.xml ,instead of importing ? 
If this is the case,then we need to run activemq-jdbc.xml when using persistance in particular
,during activemq startup.

I will try this approach and get back to you earliest. kindly let me know for any suggestions.

                
> Unable to load custom properties from credentials.properties file located in conf folder
of ActiveMQ installation directory
> ---------------------------------------------------------------------------------------------------------------------------
>
>                 Key: AMQ-4193
>                 URL: https://issues.apache.org/jira/browse/AMQ-4193
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: activemq-pool, Connector
>    Affects Versions: 5.5.1
>         Environment: I have ActiveMQ Version 5.5.1 installed on my linux[RHEL] box.
>            Reporter: Jessy
>            Priority: Critical
>         Attachments: activemq-jdbc.xml, activemq.log, activemq.xml, credentials.properties,
log4j.properties
>
>
> Hi Developers,
> I basically wanted to read some custom properties from a credentials.property file located
in conf folder of AMQ installation directory [/opt/apache/installed/activemq55-5.5.1/conf]
> Steps :
> 1. I put my custom entries in credentials.properties file , with the details of,say a
given Datasource. 
> 2. Given PropertyPlaceholderConfigurer bean configurations in my activemq-jdbc. xml.
> 3. I have imported "activemq-jdbc. xml" in my activemq.xml file[/opt/apache/installed/activemq55-5.5.1/conf]
> 4.When I startup activeMQ , it fails to startup. Also, I am not able to see the JDBC
related tables being created, because it failed to startup.
> 5.If I give values directly instead of reading from "credentials.properties", AMQ starts
up successfuuly and I am able to see the Tables namely "ACTIVEMQ_MSGS,ACTIVEMQ_LOCK,ACTIVEMQ_ACKS"
being created in my datasource.
> Please find attached the files. This looks like a bug to me. If not,kindly let me know
the workaround for the same.
> Regards
> Jessy

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message