activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christian Posta (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (AMQ-4195) activemq-admin bstat command predefined query isn't even run
Date Wed, 28 Nov 2012 18:30:58 GMT

     [ https://issues.apache.org/jira/browse/AMQ-4195?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Christian Posta resolved AMQ-4195.
----------------------------------

    Resolution: Fixed
    
> activemq-admin bstat command predefined query isn't even run
> ------------------------------------------------------------
>
>                 Key: AMQ-4195
>                 URL: https://issues.apache.org/jira/browse/AMQ-4195
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Broker
>    Affects Versions: 5.7.0
>            Reporter: Christian Posta
>            Assignee: Christian Posta
>            Priority: Minor
>             Fix For: 5.8.0
>
>
> The output for "bstat" and the "query command without any params" are exactly the same
for activemq-admin. This is because the query intended to be run for bstat is never run. 
> A closer look shows that the parameters passed to the runTask() method of QueryCommand
are never used. The QueryCommand.queryAddObjects field is what's used to determine what objects
to query and for the bstat command, those are never properly parsed. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message