activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Victor Antonovich (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMQ-4154) Karaf activemq feature can't be installed due to the unresolved dependencies
Date Fri, 02 Nov 2012 10:03:12 GMT

    [ https://issues.apache.org/jira/browse/AMQ-4154?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13489340#comment-13489340
] 

Victor Antonovich commented on AMQ-4154:
----------------------------------------

For example, using fresh Apache Karaf 2.3.0 installation:
{code}
[avm@3cky apache-karaf-2.3.0]$ ./bin/karaf start
        __ __                  ____      
       / //_/____ __________ _/ __/      
      / ,<  / __ `/ ___/ __ `/ /_        
     / /| |/ /_/ / /  / /_/ / __/        
    /_/ |_|\__,_/_/   \__,_/_/         

  Apache Karaf (2.3.0)

Hit '<tab>' for a list of available commands
and '[cmd] --help' for help on a specific command.
Hit '<ctrl-d>' or 'osgi:shutdown' to shutdown Karaf.

karaf@root> features:addurl mvn:org.apache.activemq/activemq-karaf/5.8-SNAPSHOT/xml/features
karaf@root> features:install activemq
Error executing command: Could not start bundle mvn:org.apache.activemq/activemq-console/5.8-SNAPSHOT
in feature(s) activemq-5.8-SNAPSHOT: Unresolved constraint in bundle org.apache.activemq.activemq-console
[74]: Unable to resolve 74.0: missing requirement [74.0] osgi.wiring.package; (&(osgi.wiring.package=org.codehaus.jackson.map)(version>=1.9.0)(!(version>=2.0.0)))
{code}
                
> Karaf activemq feature can't be installed due to the unresolved dependencies
> ----------------------------------------------------------------------------
>
>                 Key: AMQ-4154
>                 URL: https://issues.apache.org/jira/browse/AMQ-4154
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Message Store
>    Affects Versions: 5.8.0
>            Reporter: Victor Antonovich
>
> Trying to install ActiveMQ 5.8-SNAPSHOT feature compiled from latest trunk to Apache
Karaf and got next error:
> {code} 
> java.lang.Exception: Can not resolve feature:
> Unsatisfied requirement(s):
> ---------------------------
>    package:(&(package=org.codehaus.jackson.map)(version>=1.9.0)(!(version>=2.0.0)))
>       activemq-console
>    package:(&(package=org.fusesource.hawtbuf)(version>=1.9.0)(!(version>=2.0.0)))
>       activemq-console
>    package:(&(package=org.fusesource.hawtbuf.proto)(version>=1.9.0)(!(version>=2.0.0)))
>       activemq-console
> {code}
> Seems like unresolved dependencies were added in revision 1402652 (AMQ-4137 fix).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message