activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevin Earls (JIRA)" <j...@apache.org>
Subject [jira] [Reopened] (AMQ-4158) BTreeIndexTest hangs when run on Windows
Date Wed, 07 Nov 2012 22:12:12 GMT

     [ https://issues.apache.org/jira/browse/AMQ-4158?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Kevin Earls reopened AMQ-4158:
------------------------------

    Regression: Unit Test Broken

Unfortunately my first fix did not work.  I will attach another patch which should.  It converts
several tests to JUnit4, add's timeouts in the @Test annotation, and moves the code that I
think was causing the hang out of setup()

                
> BTreeIndexTest hangs when run on Windows
> ----------------------------------------
>
>                 Key: AMQ-4158
>                 URL: https://issues.apache.org/jira/browse/AMQ-4158
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Test Cases
>    Affects Versions: 5.7.0
>         Environment: Windows 2008 Server
>            Reporter: Kevin Earls
>            Priority: Minor
>             Fix For: 5.8.0
>
>         Attachments: IndexTestSupportTempDir_.patch
>
>
> BTreeIndexTest hangs when run on windows because it repeatedly tries to create/delete
the same directory, which is problematic on windows.  I've attached a patch which just adds
a timestamp to the directory name.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message