activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Massimo Paladin <Massimo.Pala...@cern.ch>
Subject Re: [DISCUSS] - ActiveMQ 5.7 release
Date Mon, 08 Oct 2012 09:39:27 GMT
Hi Steffen,

I have reproduced the problem, I opened a bug in Jira:
https://issues.apache.org/jira/browse/AMQ-4095

Cheers,
---
Massimo Paladin



On Sat, Sep 29, 2012 at 5:26 AM, swplotner <swplotner@amherst.edu> wrote:

> Hi,
>
> This might be a bit late. I have found an issue with the current
> 5.7-SNAPSHOT having to do specifically with STOMP+SSL+16KB messages.
>
> Let's say a stomp client submits an 8KB messages to a queue. Another stomp
> client subscribed to that queue receives the message just fine (tcp and
> SSL). Change the size to 20KB and you will see that the stomp client can
> easily submit messages >16KB, however the client subscribed to the queue is
> in trouble. The client only receives about the first 16KB chunk (smells
> like
> an SSL chunking problem):
>
> # Net::STOMP::Client->subscribe()
> #  encoded SUBSCRIBE frame
> #   H ack:client
> #   H destination:/queue/foo.amherst.md5
> #   H id:14cbbbb0-506108a5-12f8-5b6d-1
> #   sent 91 bytes
> #   received 1 bytes
> #   received 757 bytes
> #   received 1 bytes
> #   received 16102 bytes
>
> I have worked with Lionel and the Net::STOMP::Client library and he help me
> with the debug flags so that we can see the above problem:
>
> $Net::STOMP::Client::Debug::Flags = 16;
>
> and if I switch to non-SSL it works all fine. This problem did not exist in
> 5.6 release.
>
> Steffen
>
>
>
>
> --
> View this message in context:
> http://activemq.2283324.n4.nabble.com/DISCUSS-ActiveMQ-5-7-release-tp4656244p4657240.html
> Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message