activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (AMQ-1884) maven-activemq-plugin doesn't have proper VM transport support
Date Sun, 07 Oct 2012 10:10:02 GMT

     [ https://issues.apache.org/jira/browse/AMQ-1884?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Claus Ibsen resolved AMQ-1884.
------------------------------

    Resolution: Won't Fix
      Assignee: Claus Ibsen

VM transport is only intended for running in same JVM, not when forking the JVM.
                
> maven-activemq-plugin doesn't have proper VM transport support
> --------------------------------------------------------------
>
>                 Key: AMQ-1884
>                 URL: https://issues.apache.org/jira/browse/AMQ-1884
>             Project: ActiveMQ
>          Issue Type: Wish
>          Components: Broker
>    Affects Versions: 5.1.0
>            Reporter: Tuomas Kiviaho
>            Assignee: Claus Ibsen
>            Priority: Minor
>             Fix For: NEEDS_REVIEWED
>
>
> I tried to use broker by forking it for integration test purposes, but noticed that VM
transport doesn't work because of maven classloader created duplicate VMTransportFactory.class
instances <http://maven.apache.org/guides/mini/guide-maven-classloading.html>.
>  I even tried to create a plexus container singleton-keep-alive component <http://plexus.codehaus.org/ref/component-configuration.html>
from broker service in order to make sure that same instance of VMTransportFactory is shared
thorough integration test phases. This way I was able to create start stop goals for the plugin
which worked great at pre and post integration test phases but component failed to exist in
different plugins at integration test phase. 
> I guess the right approach is to introduce a maven build extension <http://docs.codehaus.org/display/MAVEN/Maven+2.1+Plugin+and+Extension+Loading+Design>

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message