activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Timothy Bish (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMQ-4132) Openwire+nio+ssl require to specify transport.enabledCipherSuites property
Date Wed, 24 Oct 2012 21:58:12 GMT

     [ https://issues.apache.org/jira/browse/AMQ-4132?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Timothy Bish updated AMQ-4132:
------------------------------

          Component/s: Transport
    Affects Version/s: 5.7.0
        Fix Version/s: 5.8.0
             Assignee: Timothy Bish

Seems to be related to what cipher suite is chosen, you can reproduce it by setting the wrong
one in the enabledCipherSuite option as well, the default case just shows it right away. 
                
> Openwire+nio+ssl require to specify transport.enabledCipherSuites property
> --------------------------------------------------------------------------
>
>                 Key: AMQ-4132
>                 URL: https://issues.apache.org/jira/browse/AMQ-4132
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Transport
>    Affects Versions: 5.7.0
>            Reporter: Massimo Paladin
>            Assignee: Timothy Bish
>             Fix For: 5.8.0
>
>         Attachments: NIOSSLBasicTest.java
>
>
> Hello,
> trying the openwire+nio+ssl connector I noticed that it requires to declare the {{transport.enabledCipherSuites}}
connector property or it results in an EOF exception. Is this intended?
> It is not the case with the other ssl connectors.
> Unit test attached.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message