activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "badams (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMQ-3977) receiveNoWait returns NULL when attempting to receive message from Virtual Topic
Date Thu, 16 Aug 2012 13:41:38 GMT

    [ https://issues.apache.org/jira/browse/AMQ-3977?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13435955#comment-13435955
] 

badams commented on AMQ-3977:
-----------------------------

You are correct. I wasn't aware of the prefetch configuration. Closing this issue, thanks
Tim.
                
> receiveNoWait returns NULL when attempting to receive message from Virtual Topic
> --------------------------------------------------------------------------------
>
>                 Key: AMQ-3977
>                 URL: https://issues.apache.org/jira/browse/AMQ-3977
>             Project: ActiveMQ
>          Issue Type: Bug
>    Affects Versions: 5.6.0
>         Environment: Windows
>            Reporter: badams
>
> Here are my steps that I performed:
> 1) Create Virtual Topic "VirtualTopic.Orders"
> 2) Create consumer "Consumer.A.VirtualTopic.Orders"
> 3) Publish persistent message to VirtualTopic.Orders (I see my message enqueued on my
Queue)
> 4) Attempt to synchronously read the message using the receiveNoWait() method. This returns
null.
> My current work around is using receive(timeout) method. This adds wasted time on my
server and should be fixed.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message