activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Maxim Zinal (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMQ-3984) ActiveMQ is incompatible with JDK 1.5
Date Tue, 21 Aug 2012 14:40:37 GMT
Maxim Zinal created AMQ-3984:
--------------------------------

             Summary: ActiveMQ is incompatible with JDK 1.5
                 Key: AMQ-3984
                 URL: https://issues.apache.org/jira/browse/AMQ-3984
             Project: ActiveMQ
          Issue Type: Improvement
          Components: Broker, Message Store
    Affects Versions: 5.6.0
         Environment: Debian/GNU Linux 6.0
            Reporter: Maxim Zinal
            Priority: Minor


ActiveMQ documentation claims to support Java 5, which is not currently true: at least JDK
6 is required to build and run ActiveMQ 5.6.0.

I was not able to build ActiveMQ with Sun JDK 1.5, because build fails on KahaDB with the
following error message:

[ERROR] Failed to execute goal org.apache.felix:maven-bundle-plugin:2.3.5:bundle (default-bundle)
on project kahadb: Execution default-bundle of goal org.apache.felix:maven-bundle-plugin:2.3.5:bundle
failed: An API incompatibility was encountered while executing org.apache.felix:maven-bundle-plugin:2.3.5:bundle:
java.lang.NoSuchMethodError: java.lang.String.getBytes(Ljava/nio/charset/Charset;)[B

I was able to run ActiveMQ broker under IBM JDK 5 (in WebSphere Application Server 6.1 environment)
after applying some code changes and rebuilding ActiveMQ with Oracle JDK 7 (in compatibility
mode, with "-source 1.5 -target 1.5" options).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message