activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gary Tully (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMQ-3935) JConsole browse() function does not work if useCache=false
Date Tue, 17 Jul 2012 12:08:33 GMT
Gary Tully created AMQ-3935:
-------------------------------

             Summary: JConsole browse() function does not work if useCache=false
                 Key: AMQ-3935
                 URL: https://issues.apache.org/jira/browse/AMQ-3935
             Project: ActiveMQ
          Issue Type: Bug
          Components: Broker
    Affects Versions: 5.6.0
            Reporter: Gary Tully
            Assignee: Gary Tully
             Fix For: 5.7.0


Doing a send of 20 messages in batches of 10, and a browse in between via jconsole with policy
entry useCache=false, the browse does not return 20 messages on the second call.
When a consumer does a browse, because there are some consumers in the mix, a page in occurs.
Via jmx, there are no consumers b/c jmx goes direct to the queue via the mbean.
The problem is that the browse does not force a page in from disk. So if the messages are
not cached they are not visible.
Ensuring that a browse does page in if the cache is disabled will sort this. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message