activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yves Rey (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMQ-3454) Contention on a mutex during a stress when using SimpleAuthenticationPlugin
Date Tue, 10 Jul 2012 10:41:35 GMT

    [ https://issues.apache.org/jira/browse/AMQ-3454?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13410224#comment-13410224
] 

Yves Rey commented on AMQ-3454:
-------------------------------

Hi,

looks like I faced that same issue with 5.5.0. and after doing basic verifications, I thought
that the problem was still on 5.6.0, thus I started fixing 5.5.0 myself.

I just discovered about that fix in 5.6.0, but I think there is still room for improvement,
thus I'd like to expose my ideas about fixing that issue:
- I did not work on the mutexes themselves, I'm not sure how much gain we can get by using
different type of mutex, I believe not much as the trouble is not really on the mutexes but
rather on the time it takes to make a copy of hash maps.
- I think the problem is rather that getDestinationMap should not be used at all in this case
(I actually wonder why would it be ever needed. I did not check who uses it). AuthorizationBroker
uses it only to test if a destination already exists.

Thus I simply added a method on the base class to do that check directly on the base hash
map.

If you want I can send my patch.

Best Regards,
Yves.

                
> Contention on a mutex during a stress when using SimpleAuthenticationPlugin
> ---------------------------------------------------------------------------
>
>                 Key: AMQ-3454
>                 URL: https://issues.apache.org/jira/browse/AMQ-3454
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Broker
>    Affects Versions: 5.5.0
>            Reporter: William
>            Assignee: Gary Tully
>            Priority: Critical
>             Fix For: 5.6.0
>
>         Attachments: RWLockDestinations.txt, amq-config.zip, amq-dump
>
>
> I am testing ActiveMQ 5.5 with my own stress test. I tried to implement a stress test
that use jms ressource in the same fashion that my application would do. 
> For that, I used jms template (from Spring) and  a pooled connection factory (as recommended).
I run a fixed number of thread that plublish on fixed number of topics. Each thread pick up
a topic and enter a loop that will send a message on the choosen topic.
> The issue is reproductible with SimpleAuthenticationPlugin active.  
> Configuration of the test : 
> * 100 topics
> * more than one thread per topic (actually 1500 producer threads)
> Common connection properties :
> * alwaysSessionAsync=false
> * dispatchAsync=false 
> * optimizeAcknowledge=true
> * socketBufferSize=131072&trace=true&wireFormat.cacheSize=2048&wireFormat.tcpNoDelayEnabled=true&wireFormat.tightEncodingEnabled=true&keepAlive=true&soTimeout=10000&connectionTimeout=10000\
> Producers : 
> * Message are not persistent
> * There is no transaction
> * Message expiration time is 30s
> * Unsing JMS template singleton with a PooledConnectionFactory
> * 3 JVM running 
> * connection options alwaysSyncSend=true,copyMessageOnSend=false
> Consumers :
> * just listening to each topic with a SimpleMessageListenerContainer and count messages
received
> * 3 JVM running 
> In attachment, you will find activemq config file and thread dumps. I can attach the
producer/consumers code if you need it but I think you have your own tests.
> This Jira is critical for me because security is mandatory for our use.
> If you need more information, please ask.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message