activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Timothy Bish (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMQ-3910) Send fails while using STOMP
Date Thu, 05 Jul 2012 17:54:34 GMT

    [ https://issues.apache.org/jira/browse/AMQ-3910?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13407327#comment-13407327
] 

Timothy Bish commented on AMQ-3910:
-----------------------------------

You could try turning on debug logging on the broker but you might want to also look into
the perl client's code for debugging options.
                
> Send fails while using STOMP
> ----------------------------
>
>                 Key: AMQ-3910
>                 URL: https://issues.apache.org/jira/browse/AMQ-3910
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Broker
>    Affects Versions: 5.5.1
>         Environment: linux, solaris
>            Reporter: Bhanu
>
> We're using STOMP 1.0 and broker 5.5.1. We see that sometimes while sending messages
on stomp using perl client, the send calls fails. We are providing a high enough value so
that the send does not timeout. It fails half a dozen times and eventually succeeds.
> Digging in the STOMP module shows that this exception is thrown when the output buffer
is unable to write all the data to the socket. Our message size is ~10-20mb. Can you please
provide your expertise on why the socket is not ready sometimes to send the message.
> Thanks,
> Bhanu

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message