activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gilles Scokart <gscok...@gmail.com>
Subject trunk build failing
Date Sat, 09 Jun 2012 13:48:50 GMT
The current trunk build is failing because of a parsing exception
triggered by qdox, a dependency of xbean.  It seems to not like the
generics structure.

It might not be the patch you want (and I don't know what the
consequence of this upgrade is on the artefact produced), but I
managed to continue the build with this patch (I tried first by
upgrading xbeans, and I tried also with qdox 1.9.2 because I saw a
similar defects solved in this version).

If it can help, here is the patch :

Index: activemq-core/pom.xml
===================================================================
--- activemq-core/pom.xml       (revision 1348409)
+++ activemq-core/pom.xml       (working copy)
@@ -639,6 +639,13 @@
             </goals>
           </execution>
         </executions>
+        <dependencies>
+          <dependency>
+            <groupId>com.thoughtworks.qdox</groupId>
+            <artifactId>qdox</artifactId>
+            <version>1.12</version>
+          </dependency>
+        </dependencies>
       </plugin>

       <plugin>



Gilles Scokart

Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message