activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From SuoNayi <suonayi2...@163.com>
Subject Reply:RE: Reply:Issue with ActiveMQ 5.5
Date Wed, 16 May 2012 08:26:17 GMT
This can cause first policy for queue will be applied.
remove the second policy for queue and add the deadLetterStrategy to first policy for queue.

--

Wangyin
SuoNayi2006@163.com 
 



At 2012-05-16 13:09:47,Sheetal.Kulkarni@sungard.com wrote:
>Hi,
>
>This is how I configure Dead letter queues:
>And just one more point to add , I am using activemq in transacted mode within camel.
>
><destinationPolicy>
>            <policyMap>
>              <policyEntries>
>                <policyEntry topic=">" producerFlowControl="true" memoryLimit="1mb">
>                  <pendingSubscriberPolicy>
>                    <vmCursor />
>                  </pendingSubscriberPolicy>
>                </policyEntry>
>                <policyEntry queue=">" producerFlowControl="true" memoryLimit="1mb">
>                  <!-- Use VM cursor for better latency
>                       For more information, see:
>                       
>                       http://activemq.apache.org/message-cursors.html
>                       
>                  <pendingQueuePolicy>
>                    <vmQueueCursor/>
>                  </pendingQueuePolicy>
>                  -->
>                </policyEntry>
>                				  <policyEntry queue=">" >
>		                 <deadLetterStrategy>
>		            <!--
>		              Use the prefix 'DLQ.' for the destination name, and make
>		              the DLQ a queue rather than a topic
>		            -->
>		            <individualDeadLetterStrategy
>		              queuePrefix="DLQ." useQueueForQueueMessages="true" />
>		          </deadLetterStrategy>
>		
>		 
>                </policyEntry>
>              </policyEntries>
>            </policyMap>
>        </destinationPolicy>
>
>-----Original Message-----
>From: SuoNayi [mailto:suonayi2006@163.com] 
>Sent: Wednesday, May 16, 2012 10:37 AM
>To: dev@activemq.apache.org
>Subject: Reply:Issue with ActiveMQ 5.5
>
>misconfiguration, you'd better show your activemq.xml of broker.
>
>
>--
>
>Wangyin
>SuoNayi2006@163.com 
> 
>
>
>
>At 2012-05-16 12:56:42,Sheetal.Kulkarni@sungard.com wrote:
>>
>>Hi,
>>
>>I have configured individual dead letter queues . Now when exception occurred, I expect
that I  get the message in individual dead letter queues.
>>But however activemq by default sends the message to default "ActiveMQ.DLQ" and not
to my individual queues.
>>We have system in production, please tell me if it is a known issue?
>>
>>Thanks
>>Sheetal
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message