activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carlos Sanchez (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMQ-3831) Exit code is not properly returned when using RUN_AS_USER
Date Tue, 08 May 2012 12:35:48 GMT

     [ https://issues.apache.org/jira/browse/AMQ-3831?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Carlos Sanchez updated AMQ-3831:
--------------------------------

    Attachment: activemq-initd.patch
    
> Exit code is not properly returned when using RUN_AS_USER
> ---------------------------------------------------------
>
>                 Key: AMQ-3831
>                 URL: https://issues.apache.org/jira/browse/AMQ-3831
>             Project: ActiveMQ
>          Issue Type: Bug
>    Affects Versions: 5.6.0
>            Reporter: Carlos Sanchez
>         Attachments: activemq-initd.patch
>
>
> There was an issue in the init.d scripts generated by the maven appassembler plugin that
is in ActiveMQ too
> http://jira.codehaus.org/browse/MAPPASM-113
> {quote}
> When using RUN_AS_USER (set to a different user than the current one) su is called to
call the script again. The return code of the called script is later ignored and 0 is always
returned.
> For example, status should return non zero when service is not running, but it returns
zero anyway.
> {quote}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message