activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hanno Wiegard (Updated) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMQ-3798) Network connector does not establish connections to a slave broker after master failure
Date Thu, 05 Apr 2012 13:51:23 GMT

     [ https://issues.apache.org/jira/browse/AMQ-3798?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Hanno Wiegard updated AMQ-3798:
-------------------------------

    Description: 
We have a broker A which is connected to a master/slave pair (M/S) using a network connector
with a static:failover configuration. A producer P writes to boker A and a consumer C consumes
from brokers M/S. After M fails S becomes active but the no data flows from P to C anymore.
Data seems to be stuck on A. 

The master/slave pair is a normal ActiveMQ installation (attached config files master.xml
and slave.xml). Broker A is started within a java process which runs in the TestProducer.java
code, TestConsumer.java consumes messages from the master/slave pair.

Attached testcase shows the same behaviour.

  was:
We have a broker A which is connected to a master/slave pair (M/S) using a network connector
with a static:failover configuration. A producer P writes to boker A and a consumer C consumes
from brokers M/S. After M fails S becomes active but the no data flows from P to C anymore.
Data seems to be stuck on A. 

The master/slave pair is a normal ActiveMQ installation (attached config files master.xml
and slave.xml). Broker A is started within a java process which runs in the TestProducer.java
code, TestConsumer.java consumes messages from the master/slave pair.

    
> Network connector does not establish connections to a slave broker after master failure
> ---------------------------------------------------------------------------------------
>
>                 Key: AMQ-3798
>                 URL: https://issues.apache.org/jira/browse/AMQ-3798
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Broker
>    Affects Versions: 5.6.0
>            Reporter: Hanno Wiegard
>         Attachments: MasterSlaveNetworkTest.java, TestConsumer.java, TestProducer.java,
master.xml, slave.xml
>
>
> We have a broker A which is connected to a master/slave pair (M/S) using a network connector
with a static:failover configuration. A producer P writes to boker A and a consumer C consumes
from brokers M/S. After M fails S becomes active but the no data flows from P to C anymore.
Data seems to be stuck on A. 
> The master/slave pair is a normal ActiveMQ installation (attached config files master.xml
and slave.xml). Broker A is started within a java process which runs in the TestProducer.java
code, TestConsumer.java consumes messages from the master/slave pair.
> Attached testcase shows the same behaviour.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message