activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Robison (Commented) (JIRA)" <>
Subject [jira] [Commented] (AMQNET-377) Sending to non-existent temp queue causes consumer to shutdown
Date Wed, 11 Apr 2012 22:07:17 GMT


Chris Robison commented on AMQNET-377:

Yes, but that isn't where the failing is happening. The consumers shutdown if I attempt to
send to a non-existent temp queue.
> Sending to non-existent temp queue causes consumer to shutdown
> --------------------------------------------------------------
>                 Key: AMQNET-377
>                 URL:
>             Project: ActiveMQ .Net
>          Issue Type: Bug
>          Components: ActiveMQ
>    Affects Versions: 1.5.3, 1.5.4
>         Environment: .NET client on Windows Server 2008 R2
>            Reporter: Chris Robison
>            Assignee: Jim Gomes
>            Priority: Blocker
>         Attachments: 2012-04-09.log,, activemq.xml, putty.log
> It appears as though attempting to send a message to a non-existent temp queue is causing
the consumer to shutdown. The behavior manifests itself by either the consumer ceasing to
consume messages or, if a request timeout is set, a RequestTimedOutException being thrown.
I have an NUnit project attached that I was able to reproduce the issue with. I've also attached

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message