activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Timothy Bish (Resolved) (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (AMQCPP-387) Credentials are not propagated correctly when passed through the ActiveMQConnectionFactory constructor in the CPP client API (However, it works correctly when passed through the createConnection method)
Date Sat, 14 Apr 2012 19:51:18 GMT

     [ https://issues.apache.org/jira/browse/AMQCPP-387?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Timothy Bish resolved AMQCPP-387.
---------------------------------

       Resolution: Fixed
    Fix Version/s: 3.5.0
                   3.4.2
         Assignee: Timothy Bish

Fixed on trunk and in 3.4.x branch
                
> Credentials are not propagated correctly when passed through the ActiveMQConnectionFactory
constructor in the CPP client API (However, it works correctly when passed through the createConnection
method)
> ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: AMQCPP-387
>                 URL: https://issues.apache.org/jira/browse/AMQCPP-387
>             Project: ActiveMQ C++ Client
>          Issue Type: Bug
>          Components: CMS Impl
>    Affects Versions: 3.4.1
>         Environment: RHEL4 on both client and server 
> I am using CMS v3.4.1
>            Reporter: Bhooshan Mogal
>            Assignee: Timothy Bish
>            Priority: Minor
>             Fix For: 3.4.2, 3.5.0
>
>
> I tried to connect to the an ActiveMQ server using the C++ client API. However, when
I pass the credentials (username and password) only through the ActiveMQConnectionFactory
 constructor and not through the createConnection method, the password is not shows up as
null in the server logs.
> So,
>  auto_ptr<ActiveMQConnectionFactory> connectionFactory(
>                 new ActiveMQConnectionFactory( brokerURI, "username", "password" ) );
>             try{
>                 connection = connectionFactory->createConnection();
>                 connection->start();
>             } catch( CMSException& e ) {
>                 e.printStackTrace();
>                 throw e;
>             }
> results in the server receiving the password as null. However, when the credentials are
passed through the createConnection method as well, like - 
> auto_ptr<ActiveMQConnectionFactory> connectionFactory(
>                 new ActiveMQConnectionFactory( brokerURI, "username", "password" ) );
>             try{
>                 connection = connectionFactory->createConnection("username", "password");
>                 connection->start();
>             } catch( CMSException& e ) {
>                 e.printStackTrace();
>                 throw e;
>             }
> the server receives the password correctly.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message