activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <Sheetal.Kulka...@sungard.com>
Subject Issue with 5.5.1 activemq version
Date Mon, 06 Feb 2012 13:12:56 GMT
Hi,

I am facing one issue with activemq version (5.5.1). My system configuration is as below:

1) I havetwo activemq brokers setup on different machines.
2) The first broker is configured for network and failover as below: 
              <networkConnectors>
            <networkConnector uri="static:(failover:(tcp://AP-HYB-sSCSS128:61616)?randomize=false)"
             networkTTL="2" 
			 dynamicOnly="true"
			  duplex="true"
          
           />
         </networkConnectors>

3) The client is apache camel configured for failover.  When I shut down first broker , the
apache camel client shows the 
     Log stating it is now reconnecting to other broker. However it doesn’t get connected
and it remains
   In the 'wait ' state only.
automatically reconnect
[               ActiveMQ Task-2] FailoverTransport              INFO  Successful
ly reconnected to tcp:// AP-HYB-sSCSS128:61616
[pun-ws6099/10.253.59.193:61616] FailoverTransport              WARN  Transport
(AP-HYB-sSCSS128/10.257.142.128:61616) failed, reason:  java.net.SocketException
: Software caused connection abort: recv failed, attempting to automatically rec
onnect
[               ActiveMQ Task-1] FailoverTransport              INFO  Successful
ly reconnected to tcp:// AP-HYB-sSCSS128:61616

What could be the issue?

Thanks,
Sheetal
Mime
View raw message