activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mirko Golze (Updated) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMQ-3744) FailoverTransport connects to inactive slave Broker
Date Tue, 28 Feb 2012 08:49:49 GMT

     [ https://issues.apache.org/jira/browse/AMQ-3744?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Mirko Golze updated AMQ-3744:
-----------------------------

    Attachment: activemq.test.zip

activemq.test.zip contains an unit test which demonstrates the maloperation
                
> FailoverTransport connects to inactive slave Broker
> ---------------------------------------------------
>
>                 Key: AMQ-3744
>                 URL: https://issues.apache.org/jira/browse/AMQ-3744
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Connector
>    Affects Versions: 5.5.1
>         Environment: Windows 7 x64, Java 1.6_30
>            Reporter: Mirko Golze
>         Attachments: activemq.test.zip
>
>
> The bug affects the ActiveMQ-Fuse Version 5.5.1-fuse-02-02. The version 5.5.1-fuse-00-08
is the last testet with no problem.
> when trying to connect to a failover-url with multiple failover nodes, the failover transport
connects successful already at the first node, even if it is an inactive slave. 
> Then, of course, no session can be started. The consumer is waiting all the time.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message