activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Timothy Bish (Updated) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMQ-3659) Wrapper scripts configuration needs adjusting with respect to chkconfig
Date Fri, 13 Jan 2012 15:19:39 GMT

     [ https://issues.apache.org/jira/browse/AMQ-3659?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Timothy Bish updated AMQ-3659:
------------------------------

    Description: 
activemq wrapper scripts (in bin/linux-x86-64, bin/linux-x86-32, bin/macosx) have the wrong
chkconfig directives - probably just got the start/stop levels round the wrong way:

    chkconfig: 2345 20 80
    
Starting at level 20 is probably a bit too early I would suggest & something like start
level of 80 is probably more appropriate. Problems can be seen with starting this early in
some environments, probably because other services are not up at that point such as the network
service.

Stop level of 20 is probably more appropriate as well since we want the broker to be shutdown
before the network and other services, so chkconfig directive should be something like:

    chkconfig: 2345 80 20


  was:
activemq wrapper scripts (in bin/linux-x86-64, bin/linux-x86-32, bin/macosx) have the wrong
chkconfig directives - probably just got the start/stop levels round the wrong way:

    chkconfig: 2345 20 80
    
Starting at level 20 is probably a bit too early I would suggest & something like start
level of 80 is probably more appropriate. Problems can be seen with starting this early in
some environments, probably because other services are not up at that point such as the network
service.

Stop level of 20 is probably more appropriate as well since we want the broker to be shutdown
before the network and other services, so chkconfig directive should be something like:

    chkconfig: 2345 80 20
    Also the wrapper.conf files in the same directories (except macosx) have an incorrect
value set for wrapper.java.library.path.1, e.g.


    
> Wrapper scripts configuration needs adjusting with respect to chkconfig
> -----------------------------------------------------------------------
>
>                 Key: AMQ-3659
>                 URL: https://issues.apache.org/jira/browse/AMQ-3659
>             Project: ActiveMQ
>          Issue Type: Improvement
>          Components: Broker
>    Affects Versions: 5.5.1
>            Reporter: Timothy Bish
>            Assignee: Timothy Bish
>            Priority: Trivial
>             Fix For: 5.6.0
>
>
> activemq wrapper scripts (in bin/linux-x86-64, bin/linux-x86-32, bin/macosx) have the
wrong chkconfig directives - probably just got the start/stop levels round the wrong way:
>     chkconfig: 2345 20 80
>     
> Starting at level 20 is probably a bit too early I would suggest & something like
start level of 80 is probably more appropriate. Problems can be seen with starting this early
in some environments, probably because other services are not up at that point such as the
network service.
> Stop level of 20 is probably more appropriate as well since we want the broker to be
shutdown before the network and other services, so chkconfig directive should be something
like:
>     chkconfig: 2345 80 20

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message