activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "metatech (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMQ-3640) activemq-broker.xml stays in Blueprint "GracePeriod" state forever
Date Thu, 05 Jan 2012 08:17:39 GMT

    [ https://issues.apache.org/jira/browse/AMQ-3640?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13180244#comment-13180244
] 

metatech commented on AMQ-3640:
-------------------------------

Remark 1 : On one of our Solaris development machines, the problem happens 100% of the time.
Remark 2 : although the displayed status is identical, this is a separate problem than ARIES-805.

                
> activemq-broker.xml stays in Blueprint "GracePeriod" state forever
> ------------------------------------------------------------------
>
>                 Key: AMQ-3640
>                 URL: https://issues.apache.org/jira/browse/AMQ-3640
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: activemq-camel
>    Affects Versions: 5.4.2
>         Environment: ServiceMix 4.3
>            Reporter: metatech
>
> In a small proportion of the time (about 20%) of first starting ServiceMix, the bundle
"activemq-broker.xml" stays in the "GracePeriod" forever (ie no timeout after 5 minutes).
 It is waiting for a namespace handler for the namespace "http://activemq.apache.org/schema/core",
which should be exported by the bundle "activemq-blueprint", which is declared as a OSGi fragment
of the "activemq-core" bundle.  When the problem occurs, the fragment is not properly attached
to the host bundle.  See the extract of the Karaf console : 
> {code}
> [  46] [Active     ] [            ] [       ] [   60] activemq-core (5.4.2)
> [  56] [Installed  ] [            ] [       ] [   60] activemq-blueprint (5.4.2)
> [  59] [Active     ] [GracePeriod ] [       ] [   60] activemq-broker.xml (0.0.0)
> {code}
> There are no "Hosts:" and "Fragments:" lines.
> The activemq-blueprint stays in "Installed" state instead of "Resolved", and cannot be
started manually because it is a fragment bundle.
> Proposed short-term workaround (untested) : merge both bundles "activemq-core" and "activemq-blueprint".
> Long-term solution : I guess the problem is due to a race condition between the starting
of the bundles and the discovery of the "host-fragment" relationship : maybe a 2-phase mechanism
is needed.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message