activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Timothy Bish (Created) (JIRA)" <jira+amq...@apache.org>
Subject [jira] [Created] (AMQNET-344) Performance issue creating connections when using Failover
Date Wed, 02 Nov 2011 19:49:32 GMT
Performance issue creating connections when using Failover 
-----------------------------------------------------------

                 Key: AMQNET-344
                 URL: https://issues.apache.org/jira/browse/AMQNET-344
             Project: ActiveMQ .Net
          Issue Type: Bug
          Components: ActiveMQ
    Affects Versions: 1.5.1, 1.5.0, 1.4.1
            Reporter: Timothy Bish
            Assignee: Timothy Bish
             Fix For: 1.5.2, 1.6.0


When creating connection instance using the Failover transport the time to create a connection
can be substantially longer than when using raw TcpTransport instances.  Problems exists in
the failover reconnect method and oneway send method that cause the initial send call for
ConnectionInfo to pause for up to 1 second.  Also the way that the InactivityMonitor configures
its initial activity delay check results in the delay always being zero unless one has been
set on the broker side so an initial check is always done which gets in the way of the normal
connection process.


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message