activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Timothy Bish (Created) (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMQ-3559) KahaDB NPE when loading data from previous versions
Date Fri, 21 Oct 2011 20:32:33 GMT
KahaDB NPE when loading data from previous versions
---------------------------------------------------

                 Key: AMQ-3559
                 URL: https://issues.apache.org/jira/browse/AMQ-3559
             Project: ActiveMQ
          Issue Type: Bug
          Components: Broker
    Affects Versions: 5.6.0
            Reporter: Timothy Bish
            Assignee: Timothy Bish
             Fix For: 5.6.0


When loading a data directory containing KahaDB logs from previous versions a NPE exception
can be encountered.  The new Version in 5.6 is v4 however an if statement in the MessageDatabase
still checks against a current of v3.  Code needs to be updated to use the VERSION field to
ensure its checking against the most current value.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message