activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "mikab PENG (Commented) (JIRA)" <>
Subject [jira] [Commented] (AMQ-3448) Zombie ActiveMQ Connection Dispatcher threads - seems to consume all process File Descriptors (FD leak)
Date Thu, 13 Oct 2011 07:45:11 GMT


mikab PENG commented on AMQ-3448:

sorry, the below code is test code :
public static void main(String[] argv) throws Exception {
	for (int i = 0; i < 1000; i++) {
		String url = "tcp://localhost:61616?wireFormat.maxInactivityDuration=0";
		ActiveMQConnectionFactory factory = new ActiveMQConnectionFactory(url);
		ActiveMQConnection connection = (ActiveMQConnection) factory.createConnection();


I tried the last version(5.5.0) and didn't reproduce this error.
when I run these code on 4.1.1, each connection will create a zombie thread.

> Zombie ActiveMQ Connection Dispatcher threads - seems to consume all process File Descriptors
(FD leak)
> -------------------------------------------------------------------------------------------------------
>                 Key: AMQ-3448
>                 URL:
>             Project: ActiveMQ
>          Issue Type: Bug
>    Affects Versions: 5.3.2
>         Environment: Active MQ 5.3.2
> java version "1.6.0_23"
> Java(TM) SE Runtime Environment (build 1.6.0_23-b05)
> Java HotSpot(TM) Server VM (build 19.0-b09, mixed mode)
> LSB Version: :core-3.1-amd64:core-3.1-ia32:core-3.1-noarch:graphics-3.1-amd64:graphics-3.1-ia32:graphics-3.1-noarch
> Distributor ID: CentOS
> Description: CentOS release 5.5 (Final)
> Release: 5.5
> Codename: Final
>            Reporter: Carl Allain
>            Priority: Critical
> Somehow linked to which was closed. I
am opening here as I cannot reopen the old bug and I hope that with the information I provide
here, someone will be able to have some insight of the possible cause and a fix.
> I don't know how to reproduce with a test case, but I have found 800+ of such "ActiveMQ
Connection Dispatcher" threads. I also noted that the number of FDs for the process keeps
increasing and after a few days, we have a "too many files opened" when going beyond the 1024
limit. Most of those FDs (hundreds) do look like:
> java 6700 lexo-ext 904u sock 0,5 1741176200 can't identify protocol
> There is not much activity on the system and that is still enough to get the problem.
> When we reach the limit of FDs, we get tons of stack traces in the logs, filling up the
hard disk...

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message