activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rasitha Wijesinghe (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMQ-2270) Activemq lost messages on restart
Date Tue, 09 Aug 2011 15:06:27 GMT

    [ https://issues.apache.org/jira/browse/AMQ-2270?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13081684#comment-13081684
] 

Rasitha Wijesinghe commented on AMQ-2270:
-----------------------------------------

Do you know if there is a fix for this when using jdbcPersistenceAdapter? 

I'm using 5.4.2 broker with jdbcPersistenceAdapter and was able to reproduce this bug. I created
a Consumer.*.VirtualTopic.FOO and published a message to VirtualTopic.FOO with Persistent
Delivery. Message correctly got to the queue and then I restarted the broker. Now the queue
and the message are gone. When I query ACTIVEMQ_MSGS table, I see the message and the queue
but upon restarting broker does not pick that up.

Tried the same with KahaDB and that works.

> Activemq lost messages on restart
> ---------------------------------
>
>                 Key: AMQ-2270
>                 URL: https://issues.apache.org/jira/browse/AMQ-2270
>             Project: ActiveMQ
>          Issue Type: Bug
>    Affects Versions: 5.2.0
>            Reporter: madderla prem kumar
>            Assignee: Rob Davies
>             Fix For: 5.3.0
>
>
> Hi , 
>    Have two brokers in network AMQ1 and AMQ2 and have lots of virtual topics configured
, Some consumers exists on some queues on AMQ1 and vice versa . On some queues AMQ2 have a
consumers with a selector and hence consume a certain percentage of messages and the queue
gets filled up every time my test program runs . After a certain number of test runs when
the queues on AMQ2 have about 2800 pending messages , I have observerd that the messages got
forwarded over to AMQ1 though AMQ1 have no consumers on these queues .
> After certain point producer cannot send any more messages to AMQ1 and dint see any exceptions
on the producer side (no activity on Queues in admin console) .
> Killed AMQ1 and tried to restart it , It took long time to restart and issued a kill
command again and then restarted .
> Now all my pending messages on AMQ1 have disappeared and this is what i see on console
during start up .
> INFO  BrokerService                  - Using Persistence Adapter: AMQPersistenceAdapter(/home/prem/software/apache-activemq-5.2.0/data.1)
> INFO  AMQPersistenceAdapter          - AMQStore starting using directory: /home/prem/software/apache-activemq-5.2.0/data.1
> INFO  KahaStore                      - Kaha Store using data directory /home/prem/software/apache-activemq-5.2.0/data.1/kr-store/state
> INFO  AMQPersistenceAdapter          - Active data files: []
> WARN  AMQPersistenceAdapter          - The ReferenceStore is not valid - recovering ...
> INFO  KahaStore                      - Kaha Store successfully deleted data directory
/home/prem/software/apache-activemq-5.2.0/data.1/kr-store/data
> INFO  AMQPersistenceAdapter          - Journal Recovery Started from: DataManager:(data-)
> INFO  KahaStore                      - Kaha Store using data directory /home/prem/software/apache-activemq-5.2.0/data.1/kr-store/data

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message