activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lior Okman (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMQ-3210) OutOfMemory error on ActiveMQ startup
Date Tue, 23 Aug 2011 09:04:29 GMT

    [ https://issues.apache.org/jira/browse/AMQ-3210?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13089356#comment-13089356
] 

Lior Okman commented on AMQ-3210:
---------------------------------

> Were you trying to restart the activeMQ server after a crash ? 
   
   ActiveMQ is being run with the Tanuki Software wrapper as a daemon, with the wrapper.on_exit.default
set to RESTART, so after the server crashes it is automatically being restarted.

> If so what were the conditions it crashed under?

   The application can send around the order of a few hundred messages on 6 topics on startup.
All the messages being sent are persistent, and there are 3 applications communicating via
ActiveMQ, one written in Java and two written in C++ with the CMS driver downloaded from the
project homepage. Everything is being run on the same host.

> What was the heap space allocated to activeMQ ? 

ActiveMQ is started with -Xmx512m .

> Were there any persistent messages that were delivered when you tried to start activeMQ?
If so please give the number of pending messages.

When these crashes occurred then most of the messages sent via ActiveMQ were persistent. Unfortunately,
I don't know how to check how many messages are pending, since ActiveMQ doesn't restart and
that prevents me from checking via the admin console. 

The application was modified to not send any persistent messages, and KahaDB was disabled
via the ActiveMQ configuration. After these changes the crash hasn't reoccurred.

>  As I see it huge number of persistent messages not delivered could be the issue. 

Is there anything I can do to help resolve this issue?

> OutOfMemory error on ActiveMQ startup
> -------------------------------------
>
>                 Key: AMQ-3210
>                 URL: https://issues.apache.org/jira/browse/AMQ-3210
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Message Store
>    Affects Versions: 5.4.2
>         Environment: # java -version
> java version "1.6.0_18"
> OpenJDK Runtime Environment (IcedTea6 1.8.3) (6b18-1.8.3-2~lenny1)
> OpenJDK Client VM (build 16.0-b13, mixed mode, sharing)
> # cat /etc/debian_version 
> 5.0.8
>            Reporter: Lior Okman
>            Priority: Critical
>         Attachments: activemq.xml, exception.log, kahadb.tar.bz2
>
>
> Probably due to some kind of message store corruption, when trying to start ActiveMQ,
I get OutOfMemory errors and the startup simply fails.
> This can be solved by deleting /var/local/apache-activemq/kahadb, after which ActiveMQ
starts with no issue.
> This issue doesn't always happen, and I'm not sure of a scenario that can reproduce this.
I do have a corrupted kahadb directory that reproduces the problem.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message