activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Timothy Bish (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (AMQ-3296) Remove (old version) slf4j-api lib from amq releases
Date Sat, 20 Aug 2011 21:38:27 GMT

     [ https://issues.apache.org/jira/browse/AMQ-3296?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Timothy Bish resolved AMQ-3296.
-------------------------------

       Resolution: Fixed
    Fix Version/s: 5.6.0

Fixed in trunk.  Latest releases of pax logging support slf4j 1.6.1 according to the release
notes.  

> Remove (old version) slf4j-api lib from amq releases
> ----------------------------------------------------
>
>                 Key: AMQ-3296
>                 URL: https://issues.apache.org/jira/browse/AMQ-3296
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Broker
>    Affects Versions: 5.5.0
>            Reporter: Haisheng HU
>             Fix For: 5.6.0
>
>
> The conflict versions of slf4j will cause problem if you have your own slf4j libs included
in the project.
> In my case, slf4j-api-1.6.1.jar and slf4j-log4j12-1.6.1.jar are on classpath.
> SLF4J: The requested version 1.6 by your slf4j binding is not compatible with [1.5.5,
1.5.6, 1.5.7, 1.5.8, 1.5.9, 1.5.10, 1.5.11]
> SLF4J: See http://www.slf4j.org/codes.html#version_mismatch for further details.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message